Skip to main content
 首页 » 编程设计

ruby-on-rails之在 Windows 上安装 MySQL2 Gem

2024年02月06日22youxin

我在 Windows 8.1 计算机上安装 mysql2 gem 时遇到一些问题。我按照这篇文章中的说明进行操作:

Ruby MYSQL2 gem installation on windows 7

安装mysql2 gem,我没有收到任何错误消息。

我跟着这个

bundle install  

命令,并确认安装了以下gems(使用bundle show),确认我安装了以下gems:

Using devise (3.2.2) 
Using mysql2 (0.3.14) 

然后我尝试这样做:

rails generate devise:install 

这就是我得到的:

C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/mysql2-0.3.14/lib/mysql2.rb:8:in `require': 126: The specified module could not be found.    
- C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/mysql2-0.3.14/lib/mysql2/mysql2.so (LoadError) 
    from C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/mysql2-0.3.14/lib/mysql2.rb:8:in `<top (required)>' 
    from C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/bundler-1.5.1/lib/bundler/runtime.rb:76:in `require' 
    from C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/bundler-1.5.1/lib/bundler/runtime.rb:76:in `block (2 levels) in require' 
    from C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/bundler-1.5.1/lib/bundler/runtime.rb:72:in `each' 
    from C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/bundler-1.5.1/lib/bundler/runtime.rb:72:in `block in require' 
    from C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/bundler-1.5.1/lib/bundler/runtime.rb:61:in `each' 
    from C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/bundler-1.5.1/lib/bundler/runtime.rb:61:in `require' 
    from C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/bundler-1.5.1/lib/bundler.rb:131:in `require' 
    from C:/Users/Joseph/googledrive/projects/rails/test_new_devise/config/application.rb:7:in `<top (required)>' 
    from C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/railties-4.0.2/lib/rails/commands.rb:43:in `require' 
    from C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/railties-4.0.2/lib/rails/commands.rb:43:in `<top (required)>' 
    from bin/rails:4:in `require' 
    from bin/rails:4:in `<main>' 

有什么想法吗?

解决方案:

答案是 stackoverflow 中两个答案的组合,再加上修改。 stackoverflow 引用资料是:

Ruby MYSQL2 gem installation on windows 7 ...mysql2/mysql2.so: [BUG] Segmentation fault ruby 2.0.0p247

底线:要让 mysql2 在 Windows 8.1 上使用 Ruby 2 在 64 位环境中工作,您需要执行以下操作:

  1. 清理:你来这里的原因是你可能一直在尝试 安装这个 gem,但它失败了,所以你需要进行一些清理 执行:gem 卸载 mysql2

  2. 下载适用于 Windows 的 Ruby 2.0 64 位:

http://dl.bintray.com/oneclick/rubyinstaller/rubyinstaller-2.0.0-p353-x64.exe?direct

  • 运行安装程序。记下它安装到的目录,并确保它位于用户路径中。转到

    Control Panel > System and Security > System - Advanced System Settings > Environment Variables 
    
  • 并确保ruby安装目录的bin目录的路径在LOCAL用户的PATH环境变量中(如果在SYSTEM Path环境变量中也可以)

  • 下载 Ruby 2 64 位开发工具包:
  • http://cdn.rubyinstaller.org/archives/devkits/DevKit-mingw64-64-4.7.2-20130224-1432-sfx.exe

  • 运行安装程序并记下安装目录的位置。说明表明,完成安装后,您需要运行 devkitvars.bat 文件来设置环境变量。这不适用于 Windows 8.1。您需要重复上面#2中描述的设置本地路径的说明,设置本地用户添加ruby dev kit bin目录和ruby dev kit mingw bin目录的路径环境变量。例如,如果开发工具包安装到 c:\ruby2devkit,并且您将 ruby​​2 安装到 C:\Ruby200-x64 目录,则编辑路径语句如下所示:

    C:\Ruby200-x64\bin;C:\ruby2-devkit\bin;c:\ruby2-devkit\mingw\bin 
    
  • 接下来您需要安装 mysql-connector。请勿下载并运行自行安装程序。相反,下载 zip 文件并解压它。记下您将其解压到的目录(出于本文的目的,我们假设您将其解压到 c:\mysql-connector:

  • http://dev.mysql.com/downloads/file.php?id=450612

  • MySQL Connector 64 位中包含的 libmysql.lib 与 mingw64-gcc 编译器不兼容。您需要生成mingw64兼容的libmysql.lib文件。

  • 下载您需要的工具

    https://structure-svm-map.googlecode.com/files/svm-map-win.zip

  • 将此文件解压到本地目录,假设您将其解压到 c:\svm-map

  • 如前所述编辑 PATH 环境路径,现在如下所示:

    C:\Ruby200-x64\bin;C:\ruby2-devkit\bin;c:\ruby2-devkit\mingw\bin;c:\svm-map;C:\svm-map\python-mingw-lib 
    
  • 生成新的 mysql 库:

    (make sure you're running as administrator) 
     
    cd c:\mysql-connector\lib 
     
    gendef.exe libmysql.dll 
     
    dlltool -v --dllname libmysql.dll --def libmysql.def --output-lib libmysql.lib 
     
    copy libmysql.dll C:\Ruby200-x64\bin 
     
    copy libmysql.lib C:\Ruby200-x64\bin 
    
  • 按如下方式安装gem(注意使用正斜杠而不是反斜杠,如果使用反斜杠将会失败):

    gem install mysql2 --platform=ruby -- '--with-mysql-dir="C:/mysql-connector/"'

  • 希望这会有所帮助,并希望有人会关注少数想要进行 Ruby on Rails 开发的 Windows 8.1 用户。

    请您参考如下方法:

    当您安装mysql2时,你下载了它需要的lib文件了吗?

    <小时 />

    我没有在 Windows 8 上安装它,但 Windows 7 需要有 this file为 mysql 提供帮助其工作所需的依赖项。您可以看到various tutorials关于如何做到这一点,我将在此处概述一个简单的概述:

    - 解压缩mysql connector file :

    C:\mysql-connector-c-6.1.3-win32\ (或类似的路径,不带任何空格)

    - 运行 mysql2再次 gem 安装程序:

    gem uninstall mydsql 
    gem install mysql2 --platform=ruby -- '--with-mysql-lib="C:\mysql-connector\lib" --with-mysql-include="C:\mysql-connector\include" --with-mysql-dir="C:\mysql-connector"' 
    
    <小时 />

    底线是我认为你的 mysql2 gem 没有加载运行所需的文件,并且可能不会显示错误,因为它是 Windows 8