Skip to main content
 首页 » 编程设计

eclipse3.7 安装github插件错误解决

2022年07月19日127zhoujg

eclipse 版本3.7 indigo是比较经典版本,为了兼容性,喜欢在该版本上开发插件。最近安装github插件报错,错误如下:

Cannot complete the install because one or more required items could not be found.

  Software being installed: Eclipse Git Team Provider 3.1.0.201310021548-r (org.eclipse.egit.feature.group 3.1.0.201310021548-r)

  Missing requirement: Git Team Provider UI 3.1.0.201310021548-r (org.eclipse.egit.ui 3.1.0.201310021548-r) requires 'bundle org.eclipse.team.core [3.6.100,4.0.0)' but it could not be found

  Cannot satisfy dependency:

    From: Eclipse Git Team Provider 3.1.0.201310021548-r (org.eclipse.egit.feature.group 3.1.0.201310021548-r)

    To: org.eclipse.egit.ui [3.1.0.201310021548-r]

一般是因为更新地址不正确,默认地址找的是最新版本,错误信息提示版本不匹配,Eclipse是3.7版本对应的下载地址是:http://download.eclipse.org/egit/updates-1.3

这样就OK了。


本文参考链接:https://blog.csdn.net/neweastsun/article/details/51504256