Skip to main content
 首页 » 编程设计

解决eclipse中不能设置tomcat8.5

2022年07月19日169lexus

我尝试在eclipse中设置tomcat8.5时,提示错误:

The Apache Tomcat installation at this directory is version 8.5.0. A Tomcat 8.0 installation is expected.


解决版本:

打开tomcat下的catalina.jar文件,具体目录为:/lib/catalina.jar,使用winrar工具打开ServerInfo.properties文件,位置:/org/apache/catalina/util/ServerInfo.properties.

修改其中的内容为8.0.0

server.info=Apache Tomcat/8.0.8.5.4 
server.number=8.5.4.0 
server.built=Jul 6 2016 08:43:30 UTC
修改为:

server.info=Apache Tomcat/8.0.0 
server.number=8.0.0 
server.built=May 11 2016 21:49:07 UTC
重启eclipse,可以设置tomcat8.5了。

ScreenShot of eclipse

我使用mars可以使用,如果其他eclipse版本还是不行,建议Help → Check for Updates,安装更新试试。



本文参考链接:https://blog.csdn.net/neweastsun/article/details/52774196